해피그래머

SpringJUnit4ClassRunner requires JUnit 4.12 or higher 본문

Java/error

SpringJUnit4ClassRunner requires JUnit 4.12 or higher

해피그래머 happygrammer 2017.06.18 23:38


에러 로그를 잘 읽고 해석해야 삽질을 줄이고 개발을 정상화 할 수 있다. 많은 에러로그가 나타나도 문제 해결의 단서를 제공하는 에러로그는 몇개의 줄에 해당한다. JPA 서비스를 Junit로 테스트 하기 위해 빌드를 진행해 보니 다음과 같은 에러가 발생했다.



전체 로그는 다음과 같았다.

java.lang.ExceptionInInitializerError
    at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
    at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
    at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
    at java.lang.reflect.Constructor.newInstance(Unknown Source)
    at org.junit.internal.builders.AnnotatedBuilder.buildRunner(AnnotatedBuilder.java:31)
    at org.junit.internal.builders.AnnotatedBuilder.runnerForClass(AnnotatedBuilder.java:24)
    at org.junit.runners.model.RunnerBuilder.safeRunnerForClass(RunnerBuilder.java:57)
    at org.junit.internal.builders.AllDefaultPossibilitiesBuilder.runnerForClass(AllDefaultPossibilitiesBuilder.java:29)
    at org.junit.runners.model.RunnerBuilder.safeRunnerForClass(RunnerBuilder.java:57)
    at org.junit.internal.requests.ClassRequest.getRunner(ClassRequest.java:24)
    at org.eclipse.jdt.internal.junit4.runner.JUnit4TestLoader.createUnfilteredTest(JUnit4TestLoader.java:84)
    at org.eclipse.jdt.internal.junit4.runner.JUnit4TestLoader.createTest(JUnit4TestLoader.java:70)
    at org.eclipse.jdt.internal.junit4.runner.JUnit4TestLoader.loadTests(JUnit4TestLoader.java:43)
    at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTests(RemoteTestRunner.java:444)
    at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTests(RemoteTestRunner.java:678)
    at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.run(RemoteTestRunner.java:382)
    at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.main(RemoteTestRunner.java:192)
Caused by: java.lang.IllegalStateException: SpringJUnit4ClassRunner requires JUnit 4.12 or higher.
    at org.springframework.test.context.junit4.SpringJUnit4ClassRunner.<clinit>(SpringJUnit4ClassRunner.java:102)
    ... 17 more

에러 메시지의 핵심은 JUnit을 12버전 이상으로 업데이트 하라는 의미이다. pom.xml에 보니 현재 JUnit 버전이 4.7 버전이였다.

<dependency>
            <groupId>junit</groupId>
            <artifactId>junit</artifactId>
            <version>4.7</version>
            <scope>test</scope>
        </dependency>

다소 헷갈릴 수 있는 버전 표기인데, 4.7보다는 4.12버전이 높은 버전이다. 4.12버전을 잘못 보면 4.1.2로 오인될 수 있다는 것은 함정이다. junit은 시맨틱 버저닝엄격히 사용하지 않고 major.minor 기반으로 버전을 표기한다. 이렇게 표기하는 이유는 사용자들은 bugfix에 대한 버전 업데이트에 대해 관심 없기 때문이라고 한다.

0 Comments
댓글쓰기 폼